Si vous utilisez une version un peu ancienne d'Ubuntu, vous avez sans doute déjà rencontré des erreurs 404 lorsque vous essayez de mettre à jour ou d'installer des paquets avec la commande apt-get. La faute au dépôt des anciens paquets qui a changé de serveur. Voici comment corriger cette erreur.

  1. La solution la plus simple consiste à mettre à jour votre version d'Ubuntu. Dans une fenêtre de Terminal, saisissez la commande suivante et validez par Entrée.

    sudo apt-get dist-upgrade

  2. Votre système est mis à jour. Après un redémarrage, vous n'aurez plus d'erreur 404 lors de l'installation ou la mise à jour d'un package.

  3. Si vous ne souhaitez pas mettre à jour votre Ubuntu, vous devez indiquer au système d'utiliser un autre dépôt pour les paquets. Ouvrez un terminal puis saisissez la commande

    sudo sed -i -e 's/archive.ubuntu.com\|security.ubuntu.com/old-releases.ubuntu.com/g' /etc/apt/sources.list

  4. Saisissez enfin la commande
    sudo apt-get update

  5. Vous utilisez désormais le dépôt des paquets anciens et n'aurez plus d'erreur 404 lors de l'installation ou la mise à jour d'un package.